[package] ncurses: build C++ bindings only our toolchain supports C++
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2012 13:05:15 +0000 (13:05 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2012 13:05:15 +0000 (13:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33909 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/ncurses/Makefile

index 0b88ab6..465b60c 100644 (file)
@@ -67,6 +67,11 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+ifneq ($(INSTALL_LIBSTDCPP),y)
+CONFIGURE_ARGS += \
+       --without-cxx-binding
+endif
+
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db