lantiq: fix imagebuilder
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 May 2015 20:28:57 +0000 (20:28 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 May 2015 20:28:57 +0000 (20:28 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45851 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/image/Makefile

index 08d80ec..e24e54a 100644 (file)
@@ -244,18 +244,23 @@ endif
 endef
 
 define Image/BuildKernelLoader/Template
-       $(call PatchKernelLzma,$(1))
-       $(call Image/BuildLoader/Template,$(1))
        $(CP) $(KDIR)/loader-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-loader
        $(CP) $(KDIR)/vmlinux-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
-       $(call PatchKernelLzma,$(1),-initramfs)
-       $(call Image/BuildLoader/Template,$(1),-initramfs)
        $(CP) $(KDIR)/loader-initramfs-$(1).bin $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs-loader
        $(CP) $(KDIR)/vmlinux-initramfs-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux-initramfs
 endif
 endef
 
+define Image/Prepare/Profile
+       $(call PatchKernelLzma,$(1))
+       $(call Image/BuildLoader/Template,$(1))
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       $(call PatchKernelLzma,$(1),-initramfs)
+       $(call Image/BuildLoader/Template,$(1),-initramfs)
+endif
+endef
+
 define Image/BuildKernelTPLink/Template
        $(call PatchKernelLzma,$(1))
        $(call TPLinkImageLzma,$(1),$(2))
@@ -433,6 +438,11 @@ Image/Build/Profile/VGV7519NOR=$(call Image/Build/$(1),$(1),VGV7519NOR)
 Image/BuildKernel/Profile/VGV7519BRN=$(call Image/BuildKernel/Template,VGV7519BRN,$(1))
 Image/Build/Profile/VGV7519BRN=$(call Image/Build/$(1),$(1),VGV7519BRN,5D00008000,0x12345678,$(1))
 
+define Image/Prepare
+       $(call Image/Prepare/Profile,VG3503J)
+       $(call Image/Prepare/Profile,VG3503J_V2)
+endef
+
 endif