[tools] firmware-utils: link statically
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:27:08 +0000 (19:27 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:27:08 +0000 (19:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33117 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/firmware-utils/Makefile

index 05b588f..640dd23 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
 endef
 
 define Host/Compile