bcm53xx: image: prepare for generating serial flash images
authorrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Apr 2015 08:42:41 +0000 (08:42 +0000)
committerrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Apr 2015 08:42:41 +0000 (08:42 +0000)
There are some rare devices without NAND, like Netgear EX6200 or
TP-LINK Archer C8.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45545 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/bcm53xx/image/Makefile

index fb909c4..b299f38 100644 (file)
@@ -34,6 +34,13 @@ define Build/mkfs/squashfs
        ( cd $(KDIR); $(STAGING_DIR_HOST)/bin/ubinize -p 128KiB -m 2048 -o $(KDIR)/root-block-0x20000-min-0x800.ubi ubinize.cfg )
 endef
 
+define Build/trx-serial
+       $(STAGING_DIR_HOST)/bin/trx \
+               -o $@ \
+               -f $(word 1,$^) -a 1024 \
+               -f $(KDIR)/root.squashfs -a 0x10000 -A $(KDIR)/fs_mark
+endef
+
 define Build/trx-nand
        # kernel: always use 4 MiB (-28 B or TRX header) to allow upgrades even
        #         if it grows up between releases