set the PROFILE variable in target.mk appropriately
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 23:13:52 +0000 (23:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 23:13:52 +0000 (23:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6470 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index bd3ceb9..d0f7b9b 100644 (file)
@@ -7,6 +7,12 @@
 
 include $(TMP_DIR)/.target.mk
 
+define AddProfile
+  ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
+    PROFILE=$(1)
+  endif
+endef
+
 ifeq ($(IB),1)
 $(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
        $(CP) $< $@