add a crlf workaround similar to the one from freewrt
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2007 16:27:11 +0000 (16:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Mar 2007 16:27:11 +0000 (16:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6507 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/unpack.mk

index e533476..7813e3b 100644 (file)
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
   else
     # try to autodetect file type
   endif
+  ifneq ($(strip $(CRLF_WORKAROUND)),)
+    PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+  endif
 endif