changed pkg_install_files so one can specify the folder to install from
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Oct 2007 19:49:11 +0000 (19:49 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Oct 2007 19:49:11 +0000 (19:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9192 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 6307a1f..d90bec8 100644 (file)
@@ -122,7 +122,7 @@ define libtool_fixup_libdir
 endef
 
 define pkg_install_files
-       $(foreach install_file,$(2),$(INSTALL_DIR) $(1)/`dirname $(install_file)`; $(CP) $(PKG_INSTALL_DIR)/$(install_file) $(1)/`dirname $(install_file)`;)
+       $(foreach install_file,$(3),$(INSTALL_DIR) $(2)/`dirname $(install_file)`; $(CP) $(1)/$(install_file) $(2)/`dirname $(install_file)`;)
 endef
 
 define Build/Prepare