[tools] patch-cmdline: link statically
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:45 +0000 (19:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:45 +0000 (19:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33101 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/patch-cmdline/Makefile

index 9a3f971..a75ba83 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ PKG_NAME:=patch-cmdline
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
+       $(HOSTCC) $(HOST_CFLAGS) -include endian.h -static -o $(HOST_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
 endef
 
 define Host/Install
 endef
 
 define Host/Install