[ramips] add profile for the Edimax 3g-6200NL board
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Apr 2013 10:00:03 +0000 (10:00 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Apr 2013 10:00:03 +0000 (10:00 +0000)
http://patchwork.openwrt.org/patch/3214/

Signed-off-by: Cédric Le Moing <cedric.le-moing@laposte.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36172 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/3G-6200NL.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 4078528..de5a542 100644 (file)
@@ -52,6 +52,7 @@ case "$FIRMWARE" in
                ;;
 
        3g-6200n | \
                ;;
 
        3g-6200n | \
+       3g-6200nl | \
        3g300m | \
        air3gii | \
        all0239-3g | \
        3g300m | \
        air3gii | \
        all0239-3g | \
index 104f201..6549726 100755 (executable)
@@ -18,6 +18,9 @@ case $board in
                set_wifi_led "edimax:amber:wlan"
                set_usb_led "edimax:blue:3g"
                ;;
                set_wifi_led "edimax:amber:wlan"
                set_usb_led "edimax:blue:3g"
                ;;
+       3g-6200nl)
+               set_wifi_led "edimax:green:wlan"
+               ;;
        3g300m)
                set_usb_led "tenda:blue:3g"
                ;;
        3g300m)
                set_usb_led "tenda:blue:3g"
                ;;
index d6ab75a..7d30f72 100755 (executable)
@@ -46,6 +46,7 @@ ramips_setup_interfaces()
                ;;
 
        dir-615-h1 | \
                ;;
 
        dir-615-h1 | \
+       3g-6200nl | \
        wl-330n)
                ucidef_set_interface_lan "eth0.1"
                ;;
        wl-330n)
                ucidef_set_interface_lan "eth0.1"
                ;;
index fcfb86b..e860309 100644 (file)
@@ -10,6 +10,7 @@ preinit_set_mac_address() {
 
        case $(ramips_board_name) in
        3g-6200n |\
 
        case $(ramips_board_name) in
        3g-6200n |\
+       3g-6200nl |\
        3g300m | \
        mzk-w300nh2 |\
        wl-330n |\
        3g300m | \
        mzk-w300nh2 |\
        wl-330n |\
index 6638b0a..2a713f8 100755 (executable)
@@ -33,6 +33,9 @@ ramips_board_detect() {
        *"Edimax 3g-6200n")
                name="3g-6200n"
                ;;
        *"Edimax 3g-6200n")
                name="3g-6200n"
                ;;
+       *"Edimax 3g-6200nl")
+               name="3g-6200nl"
+               ;;
        *"AirLive Air3GII")
                name="air3gii"
                ;;
        *"AirLive Air3GII")
                name="air3gii"
                ;;
index 97cc382..a6f52cd 100755 (executable)
@@ -15,6 +15,7 @@ platform_check_image() {
 
        case "$board" in
        3g-6200n | \
 
        case "$board" in
        3g-6200n | \
+       3g-6200nl | \
        3g300m | \
        air3gii | \
        all0239-3g | \
        3g300m | \
        air3gii | \
        all0239-3g | \
diff --git a/target/linux/ramips/dts/3G-6200NL.dts b/target/linux/ramips/dts/3G-6200NL.dts
new file mode 100644 (file)
index 0000000..f57ccfb
--- /dev/null
@@ -0,0 +1,78 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "3G-6200N", "ralink,rt3050-soc";
+       model = "Edimax 3g-6200n";
+
+       memorydetect {
+               ralink,memory = <0x0 0x200000 0x4000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600 mtdparts=1f000000.cfi:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,128k@0x3e0000(cimage)ro,3648k@0x50000(firmware)";
+       };
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmmux = "i2c", "spi", "uartlite", "jtag", "mdio", "sdram", "rgmii";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+       };
+
+       ethernet@10100000 {
+               status = "okay";
+       };
+
+       esw@10110000 {
+               status = "okay";
+               ralink,portmap = <0x2f>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               wlan {
+                       label = "edimax:amber:wlan";
+                       gpios = <&gpio0 14 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x211>;
+               };
+       };
+
+       wmac@10180000 {
+               status = "okay";
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index bb88921..01425b4 100644 (file)
@@ -238,7 +238,9 @@ endif
 #
 
 edimax_3g6200n_mtd_size=3735552
 #
 
 edimax_3g6200n_mtd_size=3735552
-Image/Build/Profile/3G6200N=$(call BuildFirmware/CustomFlash/$(1),$(1),3g-6200n,3G-6200N,$(edimax_3g6200n_mtd_size))
+Image/Build/Profile/3G6200N=$(call BuildFirmware/Edimax/$(1),$(1),3g-6200n,3G-6200N,$(edimax_3g6200n_mtd_size),CSYS,3G62,0x50000,0xc0000)
+
+Image/Build/Profile/3G6200NL=$(call BuildFirmware/Edimax/$(1),$(1),3g-6200nl,3G-6200NL,$(edimax_3g6200n_mtd_size),CSYS,3G62,0x50000,0xc0000)
 
 Image/Build/Profile/3G300M=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),3g300m,3G300M,$(ralink_default_fw_size_4M),3G150M_SPI Kernel Image,factory)
 
 
 Image/Build/Profile/3G300M=$(call BuildFirmware/CustomFlashFactory/$(1),$(1),3g300m,3G300M,$(ralink_default_fw_size_4M),3G150M_SPI Kernel Image,factory)
 
@@ -397,6 +399,7 @@ Image/Build/Profile/XDXRN502J=$(call BuildFirmware/Default4M/$(1),$(1),xdxrn502j
 ifeq ($(SUBTARGET),rt305x)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/3G6200N,$(1))
 ifeq ($(SUBTARGET),rt305x)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/3G6200N,$(1))
+       $(call Image/Build/Profile/3G6200NL,$(1))
        $(call Image/Build/Profile/3G300M,$(1))
        $(call Image/Build/Profile/AIR3GII,$(1))
        $(call Image/Build/Profile/ALL02393G,$(1))
        $(call Image/Build/Profile/3G300M,$(1))
        $(call Image/Build/Profile/AIR3GII,$(1))
        $(call Image/Build/Profile/ALL02393G,$(1))