util-linux: fix endianess bug and stage libraries properly
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:52:48 +0000 (16:52 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:52:48 +0000 (16:52 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36985 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/util-linux/Makefile
package/util-linux/patches/002-fix-endianess.patch [new file with mode: 0644]

index 7deb77d..ed2c10f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.21.2
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.21.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
@@ -33,7 +33,7 @@ endef
 CONFIGURE_ARGS += \
        --enable-new-mount      \
        --with-ncurses          \
 CONFIGURE_ARGS += \
        --enable-new-mount      \
        --with-ncurses          \
-       --disable-nls           \
+       --disable-nls           \
        --disable-tls           \
        --without-udev
 
        --disable-tls           \
        --without-udev
 
@@ -58,9 +58,9 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/libuuid/src/uuid.h $(1)/usr/include/uuid
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuuid/src/uuid.h $(1)/usr/include/uuid
 
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so.*} $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so.*} $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so.*} $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so*} $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so*} $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so*} $(1)/usr/lib
 endef
 
 define Package/libblkid
 endef
 
 define Package/libblkid
diff --git a/package/util-linux/patches/002-fix-endianess.patch b/package/util-linux/patches/002-fix-endianess.patch
new file mode 100644 (file)
index 0000000..4c59932
--- /dev/null
@@ -0,0 +1,13 @@
+Index: util-linux-2.21.2/libblkid/src/superblocks/swap.c
+===================================================================
+--- util-linux-2.21.2.orig/libblkid/src/superblocks/swap.c     2012-05-15 13:51:45.814410455 +0200
++++ util-linux-2.21.2/libblkid/src/superblocks/swap.c  2013-06-12 23:23:03.270742199 +0200
+@@ -48,7 +48,7 @@
+       /* SWAPSPACE2 - check for wrong version or zeroed pagecount */
+       if (strcmp(version, "2") == 0 &&
+-          (hdr->version != 1 || hdr->lastpage == 0))
++          ((hdr->version != 1 && swab32(hdr->version) != 1) || hdr->lastpage == 0))
+               return -1;
+       /* arbitrary sanity check.. is there any garbage down there? */