include: also check CONFIG_GPIOLIB for GPIO_SUPPORT
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Jul 2013 13:41:50 +0000 (13:41 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Jul 2013 13:41:50 +0000 (13:41 +0000)
Recent kernels removed GENERIC_GPIO and require GPIO capable
targets to select GPIOLIB instead, so check for both symbols.

Fixed #13814.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37166 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index 7a704e2..eeabb25 100644 (file)
@@ -163,7 +163,7 @@ ifeq ($(DUMP),1)
     .SILENT: $(TMP_CONFIG)
     .PRECIOUS: $(TMP_CONFIG)
 
-    ifneq ($(CONFIG_GENERIC_GPIO),)
+    ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
       FEATURES += gpio
     endif
     ifneq ($(CONFIG_PCI),)