update dropbear to 0.45
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2005 16:24:56 +0000 (16:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2005 16:24:56 +0000 (16:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@371 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dropbear/Makefile
package/dropbear/patches/change-user.patch
package/dropbear/patches/use-dev-urandom.patch

index 83558a3..5003130 100644 (file)
@@ -5,7 +5,7 @@
 #############################################################
 include $(TOPDIR)/rules.mk
 
-DROPBEAR_VERSION:=0.44
+DROPBEAR_VERSION:=0.45
 DROPBEAR_SOURCE:=dropbear-$(DROPBEAR_VERSION).tar.bz2
 DROPBEAR_SITE:=http://matt.ucc.asn.au/dropbear/releases/
 DROPBEAR_DIR:=$(BUILD_DIR)/dropbear-$(DROPBEAR_VERSION)
index 3dc068f..3b4a341 100644 (file)
@@ -1,6 +1,6 @@
 --- dropbear-0.44.old/svr-chansession.c        2005-02-03 02:29:44.000000000 +0100
 +++ dropbear-0.44/svr-chansession.c    2005-02-03 02:31:05.000000000 +0100
-@@ -859,10 +859,10 @@
+@@ -860,10 +860,10 @@
        /* We can only change uid/gid as root ... */
        if (getuid() == 0) {
  
index 1397283..e1424f5 100644 (file)
@@ -1,10 +1,10 @@
-diff -urN dropbear-0.44.old/options.h dropbear-0.44/options.h
---- dropbear-0.44.old/options.h        2005-03-02 23:08:07.000000000 +0100
-+++ dropbear-0.44/options.h    2005-03-03 01:12:21.000000000 +0100
-@@ -139,7 +139,7 @@
-  * will prevent Dropbear from blocking on the device. This could
+diff -urN dropbear-0.45.old/options.h dropbear-0.45/options.h
+--- dropbear-0.45.old/options.h        2005-03-14 17:12:22.000000000 +0100
++++ dropbear-0.45/options.h    2005-03-14 17:13:49.000000000 +0100
+@@ -143,7 +143,7 @@
   * however significantly reduce the security of your ssh connections
-  * if the PRNG state becomes simpler. */
+  * if the PRNG state becomes guessable - make sure you know what you are
+  * doing if you change this. */
 -#define DROPBEAR_RANDOM_DEV "/dev/random"
 +#define DROPBEAR_RANDOM_DEV "/dev/urandom"