modules: make all led and button modules used during boot priority 1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Jun 2013 08:24:25 +0000 (08:24 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Jun 2013 08:24:25 +0000 (08:24 +0000)
This makes sure the modules are symlinked in /etc/modules-boot.d/

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36892 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/input.mk
package/kernel/modules/leds.mk
package/system/button-hotplug/Makefile
package/system/gpio-button-hotplug/Makefile

index db31eb7..78fa924 100644 (file)
@@ -42,7 +42,7 @@ define KernelPackage/input-core
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
-  AUTOLOAD:=$(call AutoLoad,19,input-core)
+  AUTOLOAD:=$(call AutoLoad,19,input-core,1)
 endef
 
 define KernelPackage/input-core/description
 endef
 
 define KernelPackage/input-core/description
@@ -76,7 +76,7 @@ define KernelPackage/input-gpio-buttons
        CONFIG_INPUT_GPIO_BUTTONS \
        CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
        CONFIG_INPUT_GPIO_BUTTONS \
        CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons)
+  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
 endef
 
 define KernelPackage/input-gpio-buttons/description
 endef
 
 define KernelPackage/input-gpio-buttons/description
@@ -114,7 +114,7 @@ define KernelPackage/input-gpio-keys-polled
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
        CONFIG_KEYBOARD_GPIO_POLLED \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled)
+  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled,1)
   $(call AddDepends/input)
 endef
 
   $(call AddDepends/input)
 endef
 
@@ -162,7 +162,7 @@ define KernelPackage/input-polldev
   TITLE:=Polled Input device support
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
   TITLE:=Polled Input device support
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  AUTOLOAD:=$(call AutoLoad,20,input-polldev)
+  AUTOLOAD:=$(call AutoLoad,20,input-polldev,1)
   $(call AddDepends/input)
 endef
 
   $(call AddDepends/input)
 endef
 
index c77c7ed..980d626 100644 (file)
@@ -14,7 +14,7 @@ define KernelPackage/leds-gpio
   DEPENDS:= @GPIO_SUPPORT
   KCONFIG:=CONFIG_LEDS_GPIO
   FILES:=$(LINUX_DIR)/drivers/leds/leds-gpio.ko
   DEPENDS:= @GPIO_SUPPORT
   KCONFIG:=CONFIG_LEDS_GPIO
   FILES:=$(LINUX_DIR)/drivers/leds/leds-gpio.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-gpio)
+  AUTOLOAD:=$(call AutoLoad,60,leds-gpio,1)
 endef
 
 define KernelPackage/leds-gpio/description
 endef
 
 define KernelPackage/leds-gpio/description
@@ -126,7 +126,7 @@ define KernelPackage/ledtrig-default-on
   TITLE:=LED Default ON Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_DEFAULT_ON
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-default-on.ko
   TITLE:=LED Default ON Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_DEFAULT_ON
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-default-on.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-default-on)
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-default-on,1)
 endef
 
 define KernelPackage/ledtrig-default-on/description
 endef
 
 define KernelPackage/ledtrig-default-on/description
@@ -141,7 +141,7 @@ define KernelPackage/ledtrig-timer
   TITLE:=LED Timer Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_TIMER
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-timer.ko
   TITLE:=LED Timer Trigger
   KCONFIG:=CONFIG_LEDS_TRIGGER_TIMER
   FILES:=$(LINUX_DIR)/drivers/leds/$(if $(call kernel_patchver_ge,3.10),trigger/)ledtrig-timer.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-timer)
+  AUTOLOAD:=$(call AutoLoad,50,ledtrig-timer,1)
 endef
 
 define KernelPackage/ledtrig-timer/description
 endef
 
 define KernelPackage/ledtrig-timer/description
index 35ea6d4..348ea13 100644 (file)
@@ -17,7 +17,7 @@ define KernelPackage/button-hotplug
   SUBMENU:=Other modules
   TITLE:=Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
   SUBMENU:=Other modules
   TITLE:=Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/button-hotplug.ko
-  AUTOLOAD:=$(call AutoLoad,30,button-hotplug)
+  AUTOLOAD:=$(call AutoLoad,30,button-hotplug,1)
   KCONFIG:=
 endef
 
   KCONFIG:=
 endef
 
index adb9a45..1778aad 100644 (file)
@@ -17,7 +17,7 @@ define KernelPackage/gpio-button-hotplug
   SUBMENU:=Other modules
   TITLE:=Simple GPIO Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/gpio-button-hotplug.ko
   SUBMENU:=Other modules
   TITLE:=Simple GPIO Button Hotplug driver
   FILES:=$(PKG_BUILD_DIR)/gpio-button-hotplug.ko
-  AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug)
+  AUTOLOAD:=$(call AutoLoad,30,gpio-button-hotplug,1)
   KCONFIG:=
 endef
 
   KCONFIG:=
 endef