[ramips] fix prepare_generic_squashfs
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Apr 2013 11:54:09 +0000 (11:54 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Apr 2013 11:54:09 +0000 (11:54 +0000)
prepare_generic_squashfs was called twice on the generated images breaking mount_root

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36349 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index 7a9c6ae..4e8cde7 100644 (file)
@@ -500,10 +500,6 @@ endif
 #
 # Generic Targets
 #
-define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
-
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(VMLINUX).elf
        cp $(KDIR)/vmlinux $(BIN_DIR)/$(VMLINUX).bin