odhcp6c: remove IPv6 forwarding-sysctl workaround
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jan 2013 10:13:44 +0000 (10:13 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 29 Jan 2013 10:13:44 +0000 (10:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35370 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script

index 0d66272..6ac2c67 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-01-28
+PKG_VERSION:=2013-01-29
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index f2161c2..be91d16 100755 (executable)
@@ -10,7 +10,6 @@ ipv6_conf() {
 prepare_interface() {
        local device="$1"
        ipv6_conf "$device" accept_ra 2
-       ipv6_conf "$device" forwarding 2
 
        # Send RS
        if [ -x /usr/sbin/6relayd ]; then
@@ -24,8 +23,7 @@ prepare_interface() {
 
 cleanup_interface() {
        local device="$1"
-       ipv6_conf "$device" accept_ra 1
-       ipv6_conf "$device" forwarding 1
+       ipv6_conf "$device" accept_ra 0
 }
 
 setup_interface () {