cns3xxx: add sysupgrade support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Oct 2012 23:24:02 +0000 (23:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Oct 2012 23:24:02 +0000 (23:24 +0000)
Signed-off-by: Tim Harvey <tharvey@gateworks.com>
 target/linux/cns3xxx/base-files/lib/cns3xxx.sh          |   22 ++
 target/linux/cns3xxx/base-files/lib/upgrade/platform.sh |  122 ++++++++++++++++
 target/linux/cns3xxx/image/Makefile                     |   19 +-
 3 files changed, 159 insertions(+), 4 deletions(-)

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33650 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/cns3xxx/base-files/lib/cns3xxx.sh [new file with mode: 0644]
target/linux/cns3xxx/base-files/lib/upgrade/platform.sh [new file with mode: 0644]
target/linux/cns3xxx/image/Makefile

diff --git a/target/linux/cns3xxx/base-files/lib/cns3xxx.sh b/target/linux/cns3xxx/base-files/lib/cns3xxx.sh
new file mode 100644 (file)
index 0000000..d446777
--- /dev/null
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+
+cns3xxx_board_name() {
+        local machine
+        local name
+
+        machine=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /Hardware/ {print $2}' /proc/cpuinfo)
+
+        case "$machine" in
+               "Gateworks Corporation Laguna"*)
+                       name="laguna"
+                       ;;
+               *)
+                       name="generic";
+                       ;;
+       esac
+       
+       echo $name
+}
diff --git a/target/linux/cns3xxx/base-files/lib/upgrade/platform.sh b/target/linux/cns3xxx/base-files/lib/upgrade/platform.sh
new file mode 100644 (file)
index 0000000..5990991
--- /dev/null
@@ -0,0 +1,122 @@
+. /lib/cns3xxx.sh
+
+RAMFS_COPY_DATA="/lib/cns3xxx.sh"
+
+CI_BLKSZ=65536
+
+platform_find_partitions() {
+       local first dev size erasesize name
+       while read dev size erasesize name; do
+               name=${name#'"'}; name=${name%'"'}
+               case "$name" in
+                       vmlinux.bin.l7|kernel|linux|rootfs)
+                               if [ -z "$first" ]; then
+                                       first="$name"
+                               else
+                                       echo "$erasesize:$first:$name"
+                                       break
+                               fi
+                       ;;
+               esac
+       done < /proc/mtd
+}
+
+platform_find_kernelpart() {
+       local part
+       for part in "${1%:*}" "${1#*:}"; do
+               case "$part" in
+                       vmlinux.bin.l7|kernel|linux)
+                               echo "$part"
+                               break
+                       ;;
+               esac
+       done
+}
+
+platform_do_upgrade_combined() {
+       local partitions=$(platform_find_partitions)
+       local kernelpart=$(platform_find_kernelpart "${partitions#*:}")
+       local erase_size=$((0x${partitions%%:*})); partitions="${partitions#*:}"
+       local kern_length=0x$(dd if="$1" bs=2 skip=1 count=4 2>/dev/null)
+       local kern_blocks=$(($kern_length / $CI_BLKSZ))
+       local root_blocks=$((0x$(dd if="$1" bs=2 skip=5 count=4 2>/dev/null) / $CI_BLKSZ))
+
+       v "platform_do_upgrade_combined"
+       v "partitions=$partitions"
+       v "kernelpart=$kernelpart"
+       v "erase_size=$erase_size" 
+       v "kern_blocks=$kern_blocks"
+       v "root_blocks=$root_blocks"
+
+       if [ -n "$partitions" ] && [ -n "$kernelpart" ] && \
+          [ ${kern_blocks:-0} -gt 0 ] && \
+          [ ${root_blocks:-0} -gt 0 ] && \
+          [ ${erase_size:-0} -gt 0 ];
+       then
+               local append=""
+               [ -f "$CONF_TAR" -a "$SAVE_CONFIG" -eq 1 ] && append="-j $CONF_TAR"
+
+               dd if="$1" bs=$CI_BLKSZ skip=1 count=$kern_blocks 2>/dev/null | mtd write - kernel
+               dd if="$1" bs=$CI_BLKSZ skip=$((1+$kern_blocks)) count=$root_blocks 2>/dev/null | \
+                                mtd -r $append write - rootfs
+       else
+               echo "invalid image"
+       fi
+}
+
+platform_check_image() {
+       local board=$(cns3xxx_board_name)
+       local magic="$(get_magic_word "$1")"
+       local magic_long="$(get_magic_long "$1")"
+
+       [ "$ARGC" -gt 1 ] && return 1
+
+       case "$board" in
+       laguna)
+               [ "$magic" != "4349" ] && {
+                       echo "Invalid image. Use *-sysupgrade.bin files on this board"
+                       return 1
+               }
+
+               local md5_img=$(dd if="$1" bs=2 skip=9 count=16 2>/dev/null)
+               local md5_chk=$(dd if="$1" bs=$CI_BLKSZ skip=1 2>/dev/null | md5sum -); md5_chk="${md5_chk%% *}"
+
+               if [ -n "$md5_img" -a -n "$md5_chk" ] && [ "$md5_img" = "$md5_chk" ]; then
+                       return 0
+               else
+                       echo "Invalid image. Contents do not match checksum (image:$md5_img calculated:$md5_chk)"
+                       return 1
+               fi
+               return 0
+               ;;
+       esac
+
+       echo "Sysupgrade is not yet supported on $board."
+       return 1
+}
+
+platform_do_upgrade() {
+       local board=$(cns3xxx_board_name)
+
+       v "board=$board"
+       case "$board" in
+       laguna)
+               platform_do_upgrade_combined "$ARGV"
+               ;;
+       *)
+               default_do_upgrade "$ARGV"
+               ;;
+       esac
+}
+
+disable_watchdog() {
+       v "killing watchdog"
+       killall watchdog
+       ( ps | grep -v 'grep' | grep '/dev/watchdog' ) && {
+               echo 'Could not disable watchdog'
+               return 1
+       }
+}
+
+# CONFIG_WATCHDOG_NOWAYOUT=y - can't kill watchdog unless kernel cmdline has a mpcore_wdt.nowayout=0
+#append sysupgrade_pre_upgrade disable_watchdog
index 271d5ea..05a0f4f 100644 (file)
@@ -21,21 +21,32 @@ define Image/BuildKernel
        cp $(KDIR)/uImage-new $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
+# Build sysupgrade image
+define BuildFirmware/Generic
+       dd if=$(BIN_DIR)/openwrt-$(BOARD)-uImage of=$(KDIR)/uImage.pad bs=64k conv=sync; \
+       dd if=$(KDIR)/root.$(1) of=$(KDIR)/root.$(1).pad bs=128k conv=sync; \
+       sh $(TOPDIR)/scripts/combined-image.sh \
+               $(KDIR)/uImage.pad \
+               $(KDIR)/root.$(1).pad \
+               $(BIN_DIR)/$(IMG_PREFIX)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))-sysupgrade.bin
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
+       $(call BuildFirmware/Generic,$(1))
 endef
 
 define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
 endef
 
 define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
 endef
 
 define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+       $(call prepare_generic_squashfs,$(KDIR)/root.$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))