[buildroot] allow download urls using the file:// schema (#6480)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jan 2010 19:38:53 +0000 (19:38 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 13 Jan 2010 19:38:53 +0000 (19:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19120 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk

index 78848b9..a50a5e9 100644 (file)
@@ -11,7 +11,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 define dl_method 
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
+    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://% file://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \