ar71xx: allow mktplinkfw calls from the new image code to fail (because of oversized...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 May 2015 14:02:50 +0000 (14:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 May 2015 14:02:50 +0000 (14:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45646 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 00d61ba..d6e6285 100644 (file)
@@ -51,15 +51,14 @@ endef
 # -s strip padding from end of the image
 # -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
 define Build/mktplinkfw
-       $(STAGING_DIR_HOST)/bin/mktplinkfw \
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
                -k $(word 1,$^) \
                -r $@ \
                -o $@.new \
                -j -X 0x40000 \
                -a $(call rootfs_align,$(FILESYSTEM)) \
-               $(if $(findstring sysupgrade,$1),-s)
-       @mv $@.new $@
+               $(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
 endef
 
 # -c combined image