gcc: set the isl/cloog prefix when graphite is enabled, disable it explicitly if...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Nov 2015 11:35:41 +0000 (11:35 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 13 Nov 2015 11:35:41 +0000 (11:35 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47465 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk

index 5214765..0ac7de1 100644 (file)
@@ -108,6 +108,16 @@ ifdef CONFIG_USE_UCLIBC
   export glibcxx_cv_c99_math_tr1=no
 endif
 
+ifdef CONFIG_GCC_USE_GRAPHITE
+  ifdef CONFIG_GCC_VERSION_4_8
+    GRAPHITE_CONFIGURE=--with-cloog=$(REAL_STAGING_DIR_HOST)
+  else
+    GRAPHITE_CONFIGURE=--with-isl=$(REAL_STAGING_DIR_HOST)
+  endif
+else
+  GRAPHITE_CONFIGURE=--without-isl --without-cloog
+endif
+
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
        $(if $(shell gcc --version 2>&1 | grep LLVM), \