package/kernel: remove SetDepends not needed anymore
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Oct 2011 13:11:06 +0000 (13:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Oct 2011 13:11:06 +0000 (13:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28653 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/001-depends.mk
package/kernel/modules/lib.mk
package/kernel/modules/other.mk

index 238799e..93aaeb3 100644 (file)
@@ -1,37 +1,20 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
-endef
-
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
-endef
-
-
-define SetDepends/hid
-  DEPENDS:= @!TARGET_x86
+  DEPENDS+= +kmod-crc16 $(1)
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
-
-endef
-
-
-define SetDepends/input
-  DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
+  DEPENDS+= +kmod-hid $(1)
 endef
 
 define AddDepends/input
-  DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
+  DEPENDS+= +kmod-input-core $(1)
 endef
 
 
index 9154b2e..4b9eed4 100644 (file)
@@ -58,7 +58,6 @@ define KernelPackage/crc16
   KCONFIG:=CONFIG_CRC16
   FILES:=$(LINUX_DIR)/lib/crc16.ko
   AUTOLOAD:=$(call AutoLoad,20,crc16,1)
-  $(call SetDepends/crc16)
 endef
 
 define KernelPackage/crc16/description
index dcab71f..951f7ac 100644 (file)
@@ -260,7 +260,6 @@ define KernelPackage/hid
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call SetDepends/hid)
   $(call AddDepends/input,+kmod-input-evdev)
 endef
 
@@ -275,7 +274,6 @@ define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
-  $(call SetDepends/input)
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
   AUTOLOAD:=$(call AutoLoad,19,input-core)
 endef