move ccache to tools/ and fix potential dependency issue
[openwrt.git] / tools / Makefile
index c8fad23..8c5f699 100644 (file)
@@ -7,25 +7,32 @@
 # Main makefile for the host tools
 #
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage
+TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-$(CONFIG_CCACHE) += ccache
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
+TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
 TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
+STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
 
 all: install
 download: $(TARGETS_DOWNLOAD)
-install: $(TARGETS_INSTALL)
+compile: $(TARGETS_COMPILE)
+install: $(STAMP)
 clean: $(TARGETS_CLEAN)
 
 squashfs-compile: lzma-install
 
-TOOL_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(TOOL_STAMP_DIR):
-       mkdir -p $@
+ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
+  $(STAMP): $(TARGETS_INSTALL)
+endif
 
+$(STAMP): $(TOPDIR)/.config
+       mkdir -p $(shell dirname $@)
+       touch $@
+       
 $(STAGING_DIR)/include-host:
        @mkdir -p $@
        @$(CP) ./include/*.h $@/
@@ -33,28 +40,10 @@ $(STAGING_DIR)/include-host:
 $(TOOL_BUILD_DIR):
        @mkdir -p $@
 
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TOOL_STAMP_DIR) $(STAGING_DIR)/include-host $(TOOL_BUILD_DIR) FORCE
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-compile: %-prepare 
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-install: %-compile
-       @[ -f $(TOOL_STAMP_DIR)/.tool_$@ ] || { \
-               $(MAKE) -C $(patsubst %-install,%,$@) install; \
-       }
-       @touch $(TOOL_STAMP_DIR)/.tool_$@
-
-%-clean: FORCE
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(TOOL_STAMP_DIR)/.tool_$(patsubst %-clean,%,$@)-*
+$(eval $(call default_subtargets,$(STAGING_DIR)/include-host $(TOOL_BUILD_DIR)))
 
+ifeq ($(MAKECMDGOALS),install-targets)
+MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
+else
+.NOTPARALLEL:
+endif