target/sdk: remove obsolete make calls for the ancient package directory format
[openwrt.git] / target / sdk / files / Makefile
index 31758c1..a3fefaa 100644 (file)
@@ -1,89 +1,51 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
-
-DEVELOPER=1
-export DEVELOPER
-
-SDK=1
-export SDK
-
-export IS_TTY=$(shell tty -s && echo 1 || echo 0)
-include $(TOPDIR)/include/verbose.mk
-
-all: world
 
-define stamp
-tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile $(5) | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
-endef
-
-STAMP=$(call stamp,packageinfo,package)
-
-$(STAMP):
-       @mkdir -p tmp/info
-       @rm -f tmp/info/.stamp-packageinfo*
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+SDK:=1
+export TOPDIR LC_ALL LANG SDK
+
+world:
+
+include $(TOPDIR)/include/host.mk
+
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include package/Makefile
+
+$(package/stamp-compile): $(BUILD_DIR)/.prepared
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @mkdir -p bin/packages
        @touch $@
 
-define filedep
-$(foreach FILE,$(shell ls package/*/Makefile),
-tmp/.packageinfo: $(FILE)
-$(FILE):
-       @true
-)
-endef
-
-$(eval $(filedep))
-
-tmp/.packageinfo: $(STAMP)
-       @echo -n Collecting package info... 
-       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="packageinfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS=""
-
-package/%: FORCE
-       @$(NO_TRACE_MAKE) -s tmp/.packageinfo
-       $(MAKE) -C package $(patsubst package/%,%,$@) SDK=1
+clean: FORCE
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
 
-download: FORCE
-       $(MAKE) package/download
+dirclean: clean
+       rm -rf $(TMP_DIR)
 
-world: FORCE
-       $(MAKE) package/compile
-       -( \
-               cd package; \
-               find . -maxdepth 2 -name Config.in | \
-                       sed -e 's,/Config.in,,g' | \
-                       xargs -n1 make compile -C; \
-       )
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) ;
 
-clean: FORCE
-       rm -rf build_* bin
+world: prepare $(package/stamp-compile) FORCE
+       @$(MAKE) package/index
 
-distclean: clean
-       rm -rf dl .pkg*
+.PHONY: clean dirclean prereq prepare world
 
-.PHONY: FORCE
-FORCE:
+endif