Add initial version of the new Image Builder
[openwrt.git] / target / linux / rdc-2.6 / image / Makefile
index 13c8718..078e754 100644 (file)
@@ -11,11 +11,12 @@ define Build/Clean
 endef
 
 define Image/Prepare
+       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
 endef
 
 define Image/Build
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
-       $(STAGING_DIR)/bin/airlink -b 0 -j $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+       $(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
 endef
 
 $(eval $(call BuildImage))