Add the 93cx6 patch to generic-2.6, correctly fix dependencies on the rt2x00 drivers...
[openwrt.git] / target / linux / rdc-2.6 / Makefile
index 10a4872..dd49781 100644 (file)
@@ -9,16 +9,27 @@ include $(TOPDIR)/rules.mk
 ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC x86
-FEATURES:=broken pci jffs2
+FEATURES:=squashfs jffs2 broken
+
+LINUX_VERSION:=2.6.22.1
 
 define Target/Description
         Build firmware images for RDC3211 based routers
-        (e.g. Airlink101 AR525W)
+        (e.g. Airlink101 AR525W, Linksys WRT54R)
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+    define Kernel/SetInitramfs
+       rm -f $(BUILD_DIR)/root/sbin/init
+       ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
+       # $(CP) $(PLATFORM_DIR)/image/preinit.arch $(BUILD_DIR)/root/etc/
+       sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(BUILD_DIR)/root/etc/preinit
+    endef
+endif
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))