ramips: select kmod-rt2800-soc by default (if available)
[openwrt.git] / target / linux / ramips / modules.mk
index 0d29332..adf5e02 100644 (file)
@@ -19,8 +19,37 @@ define KernelPackage/usb-rt305x-dwc_otg
 endef
 
 define KernelPackage/usb-rt305x-dwc_otg/description
 This driver provides USB Device Controller support for the
 Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
 endef
 
 $(eval $(call KernelPackage,usb-rt305x-dwc_otg))
+
+OTHER_MENU:=Other modules
+define KernelPackage/sdhci-mt7620
+  SUBMENU:=Other modules
+  TITLE:=MT7620 SDCI
+  DEPENDS:=@TARGET_ramips_mt7620a +kmod-sdhci
+  KCONFIG:= \
+       CONFIG_MMC_SDHCI_MT7620
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/sdhci-mt7620.ko
+  AUTOLOAD:=$(call AutoProbe,sdhci-mt7620,1)
+endef
+
+$(eval $(call KernelPackage,sdhci-mt7620))
+
+I2C_RALINK_MODULES:= \
+  CONFIG_I2C_RALINK:drivers/i2c/busses/i2c-ralink
+
+define KernelPackage/i2c-ralink
+  $(call i2c_defaults,$(I2C_RALINK_MODULES),59)
+  TITLE:=Ralink I2C Controller
+  DEPENDS:=@TARGET_ramips kmod-i2c-core
+endef
+
+define KernelPackage/i2c-ralink/description
+ Kernel modules for enable ralink i2c controller.
+endef
+
+$(eval $(call KernelPackage,i2c-ralink))