ralink: add mt7621 support
[openwrt.git] / target / linux / ramips / image / Makefile
index 32047cc..82addb2 100644 (file)
@@ -29,10 +29,16 @@ define kernel_entry
 -a 0x88000000 -e 0x88000000
 endef
 else
+ifeq ($(CONFIG_SOC_MT7621),y)
+define kernel_entry
+-a 0x80001000 -e 0x80001000
+endef
+else
 define kernel_entry
 -a 0x80000000 -e 0x80000000
 endef
 endif
+endif
 
 define MkCombineduImage
        $(call PatchKernelLzma,$(2),$(3))
@@ -649,6 +655,19 @@ endif
 
 
 #
+# MT7621 Profiles
+#
+
+Image/Build/Profile/MT7621=$(call BuildFirmware/Default4M/$(1),$(1),mt7621,MT7621)
+
+ifeq ($(SUBTARGET),mt7621)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/MT7621,$(1))
+endef
+endif
+
+
+#
 # Generic Targets
 #
 define Image/BuildKernel