ramips: select kmod-rt2800-soc by default (if available)
[openwrt.git] / target / linux / ramips / Makefile
index 96d19ce..205d073 100644 (file)
@@ -8,20 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt305x rt3883 mt7620a rt288x
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
-       kmod-button-hotplug kmod-wpad-mini maccalc
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-rt2800-pci kmod-rt2800-soc wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))