define a shared IMG_PREFIX variable used as a basename for image files, it contains...
[openwrt.git] / target / linux / ps3 / image / Makefile
index 6a7773a..9eb3d93 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,8 +14,8 @@ endef
 define Image/BuildKernel
        mkdir -p $(BIN_DIR)
        cp $(KDIR)/image $(BIN_DIR)/otheros.bld
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
-       cp $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf $(TARGET_DIR)
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+       cp $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf $(TARGET_DIR)
 endef
 
 $(eval $(call BuildImage))