lantiq: use dwc2 by default on all ar9 boards
[openwrt.git] / target / linux / lantiq / Makefile
index 77aaf8d..7b79b68 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.7.2
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC