kirkwood: add support for dockstar
[openwrt.git] / target / linux / kirkwood / profiles / 110-nas.mk
index 28b1802..ebb71b7 100644 (file)
@@ -5,6 +5,23 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DOCKSTAR
+  NAME:=Seagate FreeAgent Dockstar
+  PACKAGES:= \
+       kmod-ata-core kmod-ata-marvell-sata \
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+       uboot-envtools
+endef
+
+define Profile/DOCKSTAR/Description
+ Package set compatible with Seagate FreeAgent Dockstar board.
+endef
+
+DOCKSTAR_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096 -U"
+DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,DOCKSTAR))
+
 define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \