kirkwood: add support for iomega iconnect
[openwrt.git] / target / linux / kirkwood / profiles / 110-nas.mk
index ebb71b7..185318d 100644 (file)
@@ -22,6 +22,21 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
 
 $(eval $(call Profile,DOCKSTAR))
 
 
 $(eval $(call Profile,DOCKSTAR))
 
+define Profile/ICONNECT
+  NAME:=Iomega Iconnect
+  PACKAGES:= \
+       kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))
+
 define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \
 define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \