kirkwood: convert to use the new jffs2_nand
[openwrt.git] / target / linux / kirkwood / image / Makefile
index 6fae13f..99bf864 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,25 +7,35 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+NAND_BLOCKSIZE := 2048:128k
+
 define Image/Prepare
        cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
 endef
 
 define Image/BuildKernel
 # do mach-id fixup here, if needed
-       cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+       cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
 endef
 
 define Image/Build
-       $(call Image/Build/$(1),$(1))
+       $(if $(Image/Build/$(1)), \
+               $(call Image/Build/$(1),$(1)), \
+               $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
+       )
+endef
+
+define Image/Build/jffs2-nand-2048-128k
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
+               bs=2048 conv=sync
 endef
 
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \
-               dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+               dd if=$(KDIR)/uImage bs=4096k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-       ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img
 endef
 
 $(eval $(call BuildImage))