imx6: remove obsolete VENTANA_DTS from profile
[openwrt.git] / target / linux / imx6 / profiles / 120-gateworks.mk
index a62fd1e..87b5821 100644 (file)
@@ -5,53 +5,35 @@
 # See /LICENSE for more information.
 #
 
-define Profile/IMX6Q_GW5400_A
-  NAME:=Gateworks Ventana GW5400-A
+define Profile/VENTANA
+  NAME:=Gateworks Ventana family
   PACKAGES:= \
-       kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
-       kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000
-endef
-
-define Profile/IMX6Q_GW5400_A/Description
- The Gateworks GW5400-A family of products is based on the Freescale i.MX6Q SoC
- and offers a large variety of peripherals such as:
-
-  * DDR3
-  * SPI FLASH
-  * 6x PCIe (3x with USB)
-  * Optional expansion for additional USB/PCI based periperhals
-  * 1x USB EHCI
-  * 1x USB OTG
-  * HDMI Audio/Video in/out
-  * Analog Video in/out
-  * Analog Audio in/out
-  * Gateworks System Controller
-endef
-
-$(eval $(call Profile,IMX6Q_GW5400_A))
-
-define Profile/IMX6Q_GW54XX
-  NAME:=Gateworks Ventana i.MX6 Quad GW54XX
-  PACKAGES:= \
-       kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
-       kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+       kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
+       kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+       kmod-can kmod-can-flexcan kmod-can-raw \
+       kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
+       kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
        kobs-ng
 endef
 
-define Profile/IMX6Q_GW54XX/Description
- The Gateworks GW54xx family of products is based on the Freescale i.MX6Q SoC
+define Profile/VENTANA/Description
+ The Gateworks Ventana family of products is based on the Freescale i.MX6Q SoC
  and offers a large variety of peripherals such as:
 
   * DDR3
-  * NAND FLASH
-  * 6x PCIe (3x with USB)
+  * NAND or SPI flash
+  * multiple PCIe (with USB for Cellular modems)
   * Optional expansion for additional USB/PCI based periperhals
-  * 1x USB EHCI
-  * 1x USB OTG
+  * USB EHCI
+  * USB OTG
   * HDMI Audio/Video in/out
   * Analog Video in/out
   * Analog Audio in/out
   * Gateworks System Controller
+  * Optional GPS with PPS
+  * Canbus
+  * User GPIO
+  * mSATA
 endef
 
-$(eval $(call Profile,IMX6Q_GW54XX))
+$(eval $(call Profile,VENTANA))