imx6: switch to 3.14
[openwrt.git] / target / linux / imx6 / Makefile
index c7b6a6d..d9544cf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=imx6
-BOARDNAME:=Freescale i.MX 6 Series
-FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
+BOARDNAME:=Freescale i.MX 6
+FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz nand ubifs
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfp3
+CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += \
-       kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
-
 $(eval $(call BuildTarget))