kernel: update 3.10 to 3.10.9
[openwrt.git] / target / linux / generic / patches-3.10 / 305-mips_module_reloc.patch
index ceae7fd..d8cd0e5 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-3.10/arch/mips/Makefile
-===================================================================
---- linux-3.10.orig/arch/mips/Makefile 2013-08-04 14:03:15.323485386 +0200
-+++ linux-3.10/arch/mips/Makefile      2013-08-04 14:03:15.379485387 +0200
-@@ -90,8 +90,13 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -90,8 +90,13 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
  cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib --gc-sections
@@ -16,11 +14,9 @@ Index: linux-3.10/arch/mips/Makefile
  
  ifndef CONFIG_FUNCTION_TRACER
  KBUILD_CFLAGS_KERNEL          += -ffunction-sections -fdata-sections
-Index: linux-3.10/arch/mips/include/asm/module.h
-===================================================================
---- linux-3.10.orig/arch/mips/include/asm/module.h     2013-07-01 00:13:29.000000000 +0200
-+++ linux-3.10/arch/mips/include/asm/module.h  2013-08-04 14:03:15.383485387 +0200
-@@ -11,6 +11,11 @@
+--- a/arch/mips/include/asm/module.h
++++ b/arch/mips/include/asm/module.h
+@@ -11,6 +11,11 @@ struct mod_arch_specific {
        const struct exception_table_entry *dbe_start;
        const struct exception_table_entry *dbe_end;
        struct mips_hi16 *r_mips_hi16_list;
@@ -32,11 +28,9 @@ Index: linux-3.10/arch/mips/include/asm/module.h
  };
  
  typedef uint8_t Elf64_Byte;           /* Type for a 8-bit quantity.  */
-Index: linux-3.10/arch/mips/kernel/module.c
-===================================================================
---- linux-3.10.orig/arch/mips/kernel/module.c  2013-07-01 00:13:29.000000000 +0200
-+++ linux-3.10/arch/mips/kernel/module.c       2013-08-04 15:31:24.995611431 +0200
-@@ -42,14 +42,222 @@
+--- a/arch/mips/kernel/module.c
++++ b/arch/mips/kernel/module.c
+@@ -42,14 +42,222 @@ struct mips_hi16 {
  static LIST_HEAD(dbe_list);
  static DEFINE_SPINLOCK(dbe_lock);
  
@@ -260,7 +254,7 @@ Index: linux-3.10/arch/mips/kernel/module.c
  
  int apply_r_mips_none(struct module *me, u32 *location, Elf_Addr v)
  {
-@@ -63,8 +271,39 @@
+@@ -63,8 +271,39 @@ static int apply_r_mips_32_rel(struct mo
        return 0;
  }
  
@@ -300,7 +294,7 @@ Index: linux-3.10/arch/mips/kernel/module.c
        if (v % 4) {
                pr_err("module %s: dangerous R_MIPS_26 REL relocation\n",
                       me->name);
-@@ -72,14 +311,17 @@
+@@ -72,14 +311,17 @@ static int apply_r_mips_26_rel(struct mo
        }
  
        if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
@@ -323,7 +317,7 @@ Index: linux-3.10/arch/mips/kernel/module.c
  
        return 0;
  }
-@@ -286,11 +528,32 @@
+@@ -286,11 +528,32 @@ int module_finalize(const Elf_Ehdr *hdr,
                list_add(&me->arch.dbe_list, &dbe_list);
                spin_unlock_irq(&dbe_lock);
        }