ar71xx: don't build uImages for the mikrotik subtarget
[openwrt.git] / target / linux / ar71xx / image / Makefile
index 36181e7..f2b6bef 100644 (file)
@@ -74,6 +74,7 @@ define PatchKernelGzip
        gzip -9 -c $(KDIR_TMP)/vmlinux$(3)-$(1) > $(KDIR_TMP)/vmlinux$(3)-$(1).bin.gz
 endef
 
+ifneq ($(SUBTARGET),mikrotik)
 define MkuImage
        mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
                -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
@@ -103,6 +104,7 @@ endef
 define MkuImageOKLI
        $(call MkuImage,lzma,-M 0x4f4b4c49,$(KDIR)/vmlinux.bin.lzma,$(KDIR_TMP)/vmlinux-$(1).okli)
 endef
+endif
 
 define CatFiles
        if [ $(2) -eq 0 ]; then \