ar71xx: rb2011: use board name from the hardware config
[openwrt.git] / target / linux / ar71xx / Makefile
index e80cc59..c865a54 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs targz mips16
+FEATURES:=mips16
 CPU_TYPE=34kc
-SUBTARGETS:=generic nand
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.24
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -22,8 +22,4 @@ DEFAULT_PACKAGES += \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools
 
-define Target/Description
-       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
-endef
-
 $(eval $(call BuildTarget))