imagebuilder: use file_copy to deploy files/ in the image generation phase
[openwrt.git] / target / imagebuilder / files / Makefile
index 4d0f1fe..ecaf5cc 100644 (file)
@@ -134,15 +134,7 @@ package_install: FORCE
 copy_files: FORCE
        @echo
        @echo Copying extra files
-       @( cd $(USER_FILES); find -type f ) | \
-               ( cd $(TARGET_DIR); while :; do \
-                       read FILE; \
-                       [ -z "$$FILE" ] && break; \
-                       [ -L "$$FILE" ] || continue; \
-                       echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
-                       rm -f "$$FILE"; \
-               done; )
-       $(CP) $(USER_FILES)/* $(TARGET_DIR)/
+       @$(call file_copy,$(USER_FILES)/*,$(TARGET_DIR)/)
 
 package_postinst: FORCE
        @echo