Add the 93cx6 patch to generic-2.6, correctly fix dependencies on the rt2x00 drivers...
[openwrt.git] / target / Makefile
index 709a208..4885ab9 100644 (file)
@@ -1,32 +1,55 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
 
 all: install
 
 $(BIN_DIR):
        mkdir -p $(BIN_DIR)
 
-linux-compile: utils-install lzma-install
 linux-install: $(BIN_DIR)
+image_install: linux-install
 
+IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
+
+download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
-compile: linux-compile
-install: image_clean linux-install
-clean: linux-clean utils-clean lzma-clean image_clean
+compile: linux-compile image_compile
+install: linux-install image_install 
+
+ifeq ($(CONFIG_SDK),y)
+install: sdk_install
+endif
+ifeq ($(CONFIG_IB),y)
+install: imagebuilder_install
+endif
+
+clean: linux-clean sdk-clean imagebuilder-clean image_clean
+
+prereq: FORCE
+       $(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
+       [ \! -f $(IMAGE_DIR)/Makefile ] || $(MAKE) -C $(IMAGE_DIR) prereq
+
+sdk_install: FORCE
+       $(MAKE) -C sdk install
 
 image_clean: FORCE
+       $(MAKE) -C $(IMAGE_DIR) clean
        rm -f $(BIN_DIR)/openwrt-*
+       
+image_compile: FORCE
+       $(MAKE) -C $(IMAGE_DIR) compile
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild: FORCE
-       $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-linux-imagebuilder: FORCE
-       $(MAKE) -C linux imagebuilder
+image_install: image_compile
+       $(MAKE) -C $(IMAGE_DIR) install
 
+imagebuilder_install: image_install
+       $(MAKE) -C imagebuilder install
 
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh %-update: FORCE
+       $(MAKE) -C $* $(patsubst $*-%,%,$@)