final fix for the profile selection
[openwrt.git] / target / Makefile
index 4853e3f..1b6cbb5 100644 (file)
@@ -20,7 +20,15 @@ IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
 download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
 compile: linux-compile image_compile
-install: image_clean linux-install sdk_install image_install imagebuilder_install
+install: linux-install image_install 
+
+ifeq ($(CONFIG_SDK),y)
+install: sdk_install
+endif
+ifeq ($(CONFIG_IB),y)
+install: imagebuilder_install
+endif
+
 clean: linux-clean sdk-clean imagebuilder-clean image_clean
 
 prereq: FORCE
@@ -43,14 +51,4 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))