don't run mdev on hotplug pseudo-events that come from user space
[openwrt.git] / rules.mk
index b63fcf3..e363517 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -87,8 +87,9 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
@@ -129,6 +130,26 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+# Default targets for subdirectory calls
+# Parameters:
+#      1: dependencies for the prepare step
+define default_subtargets
+  %-download: FORCE
+       $$(MAKE) -C $$(patsubst %-download,%,$$@) download
+
+  %-prepare: $(1) FORCE
+       $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
+
+  %-compile: %-prepare 
+       $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
+
+  %-install: %-compile
+       $$(MAKE) -C $$(patsubst %-install,%,$$@) install
+
+  %-clean: FORCE
+       @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
+endef
+
 
 all:
 FORCE: ;