kernel build cleanup
[openwrt.git] / rules.mk
index a6188f4..e363517 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -130,6 +130,26 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+# Default targets for subdirectory calls
+# Parameters:
+#      1: dependencies for the prepare step
+define default_subtargets
+  %-download: FORCE
+       $$(MAKE) -C $$(patsubst %-download,%,$$@) download
+
+  %-prepare: $(1) FORCE
+       $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
+
+  %-compile: %-prepare 
+       $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
+
+  %-install: %-compile
+       $$(MAKE) -C $$(patsubst %-install,%,$$@) install
+
+  %-clean: FORCE
+       @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
+endef
+
 
 all:
 FORCE: ;