kirkwood: add *plugs to uci-defaults
[openwrt.git] / rules.mk
index cc02b91..0822979 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -16,14 +16,12 @@ include $(TOPDIR)/include/verbose.mk
 
 export TMP_DIR:=$(TOPDIR)/tmp
 
-GREP_OPTIONS=
-export GREP_OPTIONS
-
 qstrip=$(strip $(subst ",,$(1)))
 #"))
 
 empty:=
 space:= $(empty) $(empty)
+comma:=,
 merge=$(subst $(space),,$(1))
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
@@ -190,9 +188,9 @@ export PKG_CONFIG
 
 HOSTCC:=gcc
 HOSTCXX:=g++
-HOST_CPPFLAGS:=-I$(STAGING_DIR_HOST)/include
+HOST_CPPFLAGS:=-I$(STAGING_DIR_HOST)/include -I$(STAGING_DIR_HOST)/usr/include
 HOST_CFLAGS:=-O2 $(HOST_CPPFLAGS)
-HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
+HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib -L$(STAGING_DIR_HOST)/usr/lib
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_AR:=$(TARGET_CROSS)ar
@@ -266,17 +264,21 @@ else
   DISABLE_IPV6:=--disable-ipv6
 endif
 
+TAR_OPTIONS:=-xf -
+
 ifeq ($(CONFIG_BUILD_LOG),y)
   BUILD_LOG:=1
 endif
 
+export BISON_PKGDATADIR:=$(STAGING_DIR_HOST)/share/bison
+export M4:=$(STAGING_DIR_HOST)/bin/m4
+
 define shvar
 V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
 endef
 
 define shexport
-$(call shvar,$(1))=$$(call $(1))
-export $(call shvar,$(1))
+export $(call shvar,$(1))=$$(call $(1))
 endef
 
 define include_mk