[package] ubox: remove empty menu from block-mount
[openwrt.git] / package / system / ubox / Makefile
index 84f5582..a300b12 100644 (file)
@@ -33,24 +33,24 @@ define Package/block-mount
   CATEGORY:=Base system
   TITLE:=Block device mounting and checking
   DEPENDS:=+ubox +libubox +libuci
-  MENU:=1
 endef
 
 define Package/ubox/install
        $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin
 
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,lsbloader,board} $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader} $(1)/sbin/
        ln -s /sbin/mount_root $(1)/sbin/switch2jffs
        ln -s /sbin/mount_root $(1)/sbin/jffs2reset
        ln -s /sbin/mount_root $(1)/sbin/jffs2mark
-       ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
+#      ln -s /sbin/kmodloader $(1)/usr/sbin/lsmod
        ln -s /sbin/kmodloader $(1)/usr/sbin/modinfo
 endef
 
 define Package/block-mount/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
        $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/