[package] ubox: remove empty menu from block-mount
[openwrt.git] / package / system / ubox / Makefile
index 3824148..a300b12 100644 (file)
@@ -33,7 +33,6 @@ define Package/block-mount
   CATEGORY:=Base system
   TITLE:=Block device mounting and checking
   DEPENDS:=+ubox +libubox +libuci
-  MENU:=1
 endef
 
 define Package/ubox/install
@@ -48,9 +47,10 @@ define Package/ubox/install
 endef
 
 define Package/block-mount/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
+       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
        $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/