procd: fix service file tracking
[openwrt.git] / package / system / procd / Makefile
index 014e01c..33ba8d1 100644 (file)
@@ -1,13 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-07-14
+PKG_VERSION:=2013-12-18
+
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=36d79a90c28ac9d655ccd8261b3ac0b497a5aec1
+PKG_SOURCE_VERSION:=2dc572df0e3002263c0a49ebbc329ed1b6c42a01
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -29,14 +30,12 @@ define Package/procd
 endef
 
 define Package/procd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/sbin  $(1)/etc $(1)/lib/functions
 
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{init,procd,askfirst,udevtrigger} $(1)/sbin/
        $(INSTALL_BIN) ./files/reload_config $(1)/sbin/
-       $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
        $(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
        $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
-       ln -s /sbin/procd $(1)/sbin/init
 endef
 
 $(eval $(call BuildPackage,procd))