brcm47xx: dont manually insmod switch drivers
[openwrt.git] / package / switch / Makefile
index 364416d..fd1504e 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,19 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kmod-switch
-PKG_RELEASE:=4
+PKG_RELEASE:=6
 
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/switch
   SUBMENU:=Other modules
-  DEPENDS:=@TARGET_brcm47xx||TARGET_brcm63xx
+  DEPENDS:=@TARGET_brcm47xx
   TITLE:=Switch drivers
   FILES:= \
        $(PKG_BUILD_DIR)/switch-core.ko \
        $(PKG_BUILD_DIR)/switch-adm.ko \
        $(PKG_BUILD_DIR)/switch-robo.ko
-  AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm)
+  AUTOLOAD:=$(call AutoLoad,20,switch-core switch-robo switch-adm,1)
 endef
 
 define KernelPackage/switch/description