openvpn: make size optimization configurable
[openwrt.git] / package / network / services / openvpn / Makefile
index 219009a..a05248c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.3.2
-PKG_RELEASE=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://swupdate.openvpn.net/community/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -66,7 +66,7 @@ CONFIGURE_VARS += \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-small \
+               $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SMALL),--enable-small) \
                --disable-selinux \
                --disable-systemd \
                --disable-plugins \