firewall3: update to git head
[openwrt.git] / package / network / config / firewall3 / Makefile
index 5ddc792..1ec8ae6 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-05-21
+PKG_VERSION:=2013-05-23
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=54904110e3122f4fcded32f5ff6ef30f7de7363c
+PKG_SOURCE_VERSION:=a93d95470803e9026c725fc7081ac8a06191ea6a
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
@@ -47,7 +47,7 @@ define Build/Compile
 endef
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections -Wl,--whole-archive
 
 define Package/firewall3/install
        $(INSTALL_DIR) $(1)/sbin