mac80211: update to wireless-testing 2012-04-13
[openwrt.git] / package / mac80211 / patches / 110-disable_usb_compat.patch
index c605801..04e9101 100644 (file)
@@ -1,6 +1,6 @@
 --- a/compat/compat-2.6.28.c
 +++ b/compat/compat-2.6.28.c
-@@ -165,7 +165,7 @@ EXPORT_SYMBOL(pcmcia_loop_config);
+@@ -165,7 +165,7 @@ EXPORT_SYMBOL_GPL(pcmcia_loop_config);
  
  #endif /* CONFIG_PCMCIA */
  
@@ -12,7 +12,7 @@
 --- a/compat/compat-2.6.29.c
 +++ b/compat/compat-2.6.29.c
 @@ -49,7 +49,7 @@ void netdev_attach_ops(struct net_device
- EXPORT_SYMBOL(netdev_attach_ops);
+ EXPORT_SYMBOL_GPL(netdev_attach_ops);
  
  #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
 -#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
@@ -22,7 +22,7 @@
   * @anchor: anchor the requests are bound to
 --- a/include/linux/compat-2.6.28.h
 +++ b/include/linux/compat-2.6.28.h
-@@ -69,7 +69,7 @@ int pcmcia_loop_config(struct pcmcia_dev
+@@ -73,7 +73,7 @@ int pcmcia_loop_config(struct pcmcia_dev
  /* USB anchors were added as of 2.6.23 */
  #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
  
  #endif
 --- a/config.mk
 +++ b/config.mk
-@@ -503,7 +503,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
+@@ -498,7 +498,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
  # This activates a threading fix for usb urb.
  # this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
  # This fix will be included in some stable releases.
--CONFIG_COMPAT_USB_URB_THREAD_FIX=y
-+# CONFIG_COMPAT_USB_URB_THREAD_FIX=y
+-export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
++# export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
  
- CONFIG_ATH9K_HTC=m
export CONFIG_ATH9K_HTC=m
  # CONFIG_ATH9K_HTC_DEBUGFS=y